Love your arranger keyboard...?

You've come to the right place! We are a honeywell of relevant information. Listen to the experts for tips and tricks. Read our blog posts to get ideas and inspiration. Expand your social network. Discover what is possible with your arranger keyboard. Visit the forum right now to get started.

Roland gw8

Topic Author
  • Posts: 2
  • Karma:
  • Gender: Unknown
  • Birthdate: Unknown
Roland gw8 #6734
Hi , looking for advice , Today i recieved delivery of a Roland GW-8 i purchased 2nd hand on E-BAY it came flightcased and with no obvious damage , but on powering it up i am getting no sound from either the headphones out or the Main left + right outs , i have followed the troubleshooter points in the manual , checked local is on , checked volume is up + that levels on parts are up in perform mixer , any advice or ideas ? ( its is not the cables or headphones it is definitely the keyboard ) Thanks in advance .
1 week 6 days ago

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Karma:
  • Gender: Unknown
  • Birthdate: Unknown
Roland gw8 #6735
I presume the display and LEDs under the panel buttons light normally? (This would assure me that you are using a power source of the correct voltage and polarity.) For the GW-8 I would use a power supply of at least 1000ma [edit] and probably more.

I would download all of the manuals, if you haven't already done so. The next thing I would do is a factory reset. If that fails to solve your problem, then I would take the back off, and look for an obvious loose connection. Work slowly in a clean environment, and take lots of pictures to aid in reassembly.

Hope you're able to get it working!
1 week 6 days ago Last edit: 1 week 6 days ago by TedS. Reason: corrected the current draw to 1000ma

Please Log in or Create an account to join the conversation.

Topic Author
  • Posts: 2
  • Karma:
  • Gender: Unknown
  • Birthdate: Unknown
Roland gw8 #6736
Thanks TedS , yeah im using a 2000ma power supply and all leds are working , Factory reset was first thing i tried and have checked the manual , so next step looks like having a look inside . thank you for your reply
1 week 6 days ago

Please Log in or Create an account to join the conversation.

  • Posts: 702
  • Karma:
  • Gender: Unknown
  • Birthdate: Unknown
Roland gw8 #6738
I'd start by checking whether all LED's etc. actually flash when a style is run. You say this is OK?

The problem seems to be that the headphone and main outs aren't really connected, so audio not present at either is unlikely to be an issue with them. The odds that BOTH don't work because of a faulty connector seems slim. One or the other, yes, but not both.

TBH, I'd send it back and get your money back. Plenty of arrangers on eBay, no point missing your return window in a vain effort to coax it back to life,

All in all, at this point, I'd probably suggest looking out for a used BK5, which is a great inexpensive arranger, and at least up to date and well supported. The GW8 is well past its shelf life, and lacks a ton of stuff from the BK series...
1 week 5 days ago
BK-9 BK-7m G70. Kurzweil K2500S, Korg Triton. Samick upright piano. iMac 27", HR824 monitors.

Please Log in or Create an account to join the conversation.

Forum Access

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add Files.
  • Not Allowed: to edit your message.